What is a LUT and a HALD?

A Look-Up Table (LUT) is a file containing math instructions to replace a color by another one. It’s like a color grading preset. This process is done pixel by pixel, that gives a very high accuracy.

A HALD is a 3D LUT converted into 2D image as PNG file. The HALD is a pattern containing all color values (pixels) for a specific size of grid. Bigger is the grid, better color accuracy is the output generated LUT.

LUT Generator will convert each pixel color difference between original HALD and modified HALD, into a LUT as .CUBE format. You can choose from two sizes of HALD/LUT: 25 or 64. Follow menu LUT Generator > Preferences to choose.

How it works

The process is very simple. You click on Generate a HALD button to generate a PNG HALD. You open this PNG into your favorite photo editing application and you apply your favorite color correction on the PNG HALD. Then you save it as PNG without compression (or in JPG 100% quality). Finally, you click Convert to CUBE and select the modified PNG you just saved. This PNG HALD will be converted into a 3D LUT as .CUBE format, compatible with almost all photo and video editing applications.

Important note: A Look-Up Table (LUT) can only affect colors, contrast, brightness, gamma, etc. So you can't add grain, noise reduction, vignetting, sharpen, etc. If you apply this kind of elements on the PNG HALD, the output LUT will be corrupted!

Some examples of use

Convert Lightroom presets for video purpose:
Apply your favorite Lightroom presets on the PNG HALD generated by this application and export in a JPG 100% sRVB. As specified above, don't use sharpen, vignetting, gradient overlay, grain or noise reduction on the PNG HALD. Only settings that affect color.
Watch a video tutorial

Use the power of Adobe Camera Raw on video:
Adobe Camera Raw is a powerful tool to color correct an image. It would be perfect to use this awesome tool on video but it's not possible at present (Adobe limitation). So here is the process with the help of LUT Generator. First, you have to extract some still frames from your video (use VLC screenshot function). Then, open a still frame into Adobe Photoshop and click menu Filter > Camera Raw Filter. Adjust your image as you want. In Camera Raw window, go to the last tab "Presets" (right sidebar) and click add new preset button icon in the bottom. Now your adjustments have been saved. Quit Camera Raw and open a PNG HALD. Go back to menu Filter > Camera Raw Filter and in the "Presets" tab, select your last preset. Apply this Camera Raw filter and save PNG HALD without compression. Now, in LUT Generator, click Convert to CUBE and select the modified PNG you just saved. A 3D LUT is generated! Now you can apply this LUT into Adobe Premiere Pro (via Lumetri effect) or with DaVinci Resolve to color grade your video.
Watch a video tutorial

Create a LUT based on Photoshop color correction:
In Photoshop you can color correct an image with advanced features or using third-party plugins. With the help of LUT Generator you'll be able to apply to filters and/or adjustment layers on the PNG HALD and convert it to LUT easily.
Since the version CS6, Photoshop is able to export adjustment layers as 3D LUT via menu File > Export > Color Lookup Tables...

Apply third-party app effects on video:
For example if you have a standalone application that can add effects on photos, like DxO FilmPack, you can apply a preset on the PNG HALD and generate a LUT to be used into Premiere Pro or DaVinci Resolve for video color grading. In the case of DxO FilmPack you'll have to disable film grain, as mentioned above.
Watch a video tutorial

Compatible applications with LUTs

- Adobe Photoshop (CS6 and +)
- Adobe After Effects (CS4 and +)
- Adobe Premiere Pro (CS5 and +)
- Adobe SpeedGrade
- Avid Media Composer (7 and +)
- The Foundry NUKE
- DaVinci Resolve
- Final Cut Pro X
- Sony Vegas
- Affinity Photo
- HitFilm 4 Pro
- and more...

Support

For any question, feel free to contact me at: contact@iwltbap.com

Get pack of 99+ unique LUTs

This pack contains LUTs as .CUBE and .3DL files (size 33x33x33), and a quick PDF guide. In total there are more than 690 LUTs in the pack (standard, LOG, V-Log, tints, gels and utility LUTs). Regularly I update this pack with new looks (lifetime free updates).

✔  200 unique and powerful LUTs
✔  15 tints LUTs combinable with looks
✔  6 gels LUTs inspired by Roscolux gel filters
✔  LUTs previewer app for Mac/PC and online
✔  LUTs DeLOG online web app
✔  Profiled on high-resolution color matrix
✔  For standard image profiles, LOG and V-Log
✔  .LOOK files for Premiere Pro CC 2015 Lumetri
✔  .VLT files to load the LUTs in Panasonic cameras (GH5, …)
✔  50+ specific LUTs to convert LOG profiles to Rec.709
✔  Skin tones preserved
✔  Lifetime free updates!
✔  Instant delivery by email :-)

Get the pack now